Back to overview
Downtime

Site is Unavailable

Jun 13 at 03:18pm EDT
Affected services
submit.gg

Resolved
Jun 13 at 03:48pm EDT

The issue has been resolved.

Created
Jun 13 at 03:18pm EDT

Our upstream provider for our front-end (submit.gg) is having an outage - unfortunately this outage impacts our ability to provide the front-end. We are working with them to resolve this issue as quickly as possible.