Back to overview
Degraded

Degraded Functionality

Jul 11 at 02:16pm EDT
Affected services
submit.gg
Core Services
Feed V3

Resolved
Jul 11 at 03:36pm EDT

A fix has been applied to all impacted services and networking performance has returned to normal.

Updated
Jul 11 at 02:26pm EDT

The issue has been identified and a fix is being implemented.

Created
Jul 11 at 02:16pm EDT

Submit is currently experiencing degraded network connectivity with one of its primary infrastructure providers. This will result in failed attempts to sign-in or access services on the platform.