Back to overview
Maintenance
Platform Upgrades
Aug 03 at 12:30pm EDT
–
Aug 28 at 10:00pm EDT
Affected services
Submit.gg
Content Storage
Resolved
Aug 22 at 06:52pm EDT
All of Submit's new services have completed validation. Unfortunately the automated process of Submit bringing itself back online didn't work as expected. Our team is now working to manually bring the platform back online as quickly as possible. We apologize for the extended downtime and appreciate your continued patience - we're almost there!
Affected services
Created
Aug 03 at 12:30pm EDT
Submit is continuing major infrastructure upgrades to support our next-generation of privacy-preserving storage and a generally improved experience. Our apologies for the downtime.
Affected services